Building a Compound Frame Relay Switch

Introduction:

The following document describes how to build a compound high density Frame Relay switch by cascading multiple routers which have a low density of interfaces. This is accomplished by connecting the routers together with a rollover cable between their AUX ports and configuring a GRE tunnel over this asynchronous connection.

Hardware Used:

  • 2 Cisco Routers with DB-60 Serial Interfaces for Frame Relay Cloud
  • 1 Rollover (Console) Cable
  • 5 DB-60 DTE/DCE Serial Cables

Configuration:

The above 2501 and 2520 routers have been connected with a rollover (console) cable between their AUX ports. The resulting effect is a 6 port Frame Relay cloud that is transparently one device from the perspective of the CPE devices, R1 through R5.

2501:
interface Serial0
 description To R1
 clock rate 2000000
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1 201
 frame-relay route 103 interface Tunnel0 103
 frame-relay route 113 interface Tunnel0 113
 frame-relay route 104 interface Tunnel0 104
 frame-relay route 105 interface Tunnel0 105
!
interface Serial1
 description To R2
 clock rate 2000000
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0 102
 frame-relay route 203 interface Tunnel0 203
 frame-relay route 213 interface Tunnel0 213
 frame-relay route 204 interface Tunnel0 204
 frame-relay route 205 interface Tunnel0 205
!
interface Async4
 ip address 12.0.0.1 255.0.0.0
 async dynamic routing
 async mode dedicated
!
interface Tunnel0
 tunnel source Async4
 tunnel destination 12.0.0.2
!
line aux 0
 modem InOut
 transport input all
 speed 38400
 flowcontrol hardware
2520:
interface Serial0
 description To R3-1
 clock rate 2000000
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay route 301 interface Tunnel0 103
 frame-relay route 302 interface Tunnel0 203
 frame-relay route 304 interface Serial2 403
 frame-relay route 305 interface Serial3 504
!
interface Serial1
 description To R3-2
 clock rate 2000000
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay route 311 interface Tunnel0 113
 frame-relay route 312 interface Tunnel0 213
 frame-relay route 314 interface Serial2 413
 frame-relay route 315 interface Serial3 514
!
interface Serial2
 description To R4
 clock rate 2000000
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay route 401 interface Tunnel0 104
 frame-relay route 402 interface Tunnel0 204
 frame-relay route 403 interface Serial0 403
 frame-relay route 413 interface Serial1 413
 frame-relay route 405 interface Serial3 504
!
interface Serial3
 description To R5
 clock rate 2000000
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay route 501 interface Tunnel0 105
 frame-relay route 502 interface Tunnel0 205
 frame-relay route 503 interface Serial0 305
 frame-relay route 513 interface Serial1 315
 frame-relay route 504 interface Serial2 405
!
interface Async4
 ip address 12.0.0.2 255.0.0.0
 async dynamic routing
 async mode dedicated
!
interface Tunnel0
 tunnel source Async4
 tunnel destination 12.0.0.1
!
line aux 0
 modem InOut
 transport input all
 speed 38400
 flowcontrol hardware

© 2006 Internetwork Expert, Inc.



Train with the Best in CCIE Cisco Certification Training. Visit www.ine.com for your CCIE Training!
 
Train with the Best in CCIE Cisco Certification Training. Visit www.ine.com for your CCIE Training! INE Twitter INE RSS Feeds INE Linked In INE Facebook INE Blog INE YouTube Ine.com meets the PCI data security requirements by passing a SecurityMetrics¬ Site Certification vulnerability scan. VeriSign Trusted BBB Reliability Report for Internetwork Expert, Inc. INE IEOC Community